Back to overview
Resolved
EU-DE-01 Downtime
Apr 18, 2026 at 9:44am UTC
Resolved
Apr 18, 2026 at 9:55am UTC
The provider has solved the issue. We apologise for any inconveniences
Affected services
Created
Apr 18, 2026 at 9:44am UTC
Our Upstream Provider is currently having issues with the Germany location. Our Team is communicating with the provider to help resolve this issue.
Affected services