Back to overview
Resolved
Panel & UK Nodes Down
Apr 21, 2026 at 3:07pm UTC
Affected services
Management Panel - panel.nemeahosting.com
Resolved
Apr 22, 2026 at 4:04pm UTC
Provider has fixed the ongoing issues. Everything is restored.
Affected services
Created
Apr 21, 2026 at 3:07pm UTC
Our upstream provider is having issues with storage. We are working with the provider to resolve this issue.
Affected services