Back to overview
Resolved

Panel & UK Nodes Down

May 1, 2026 at 3:59pm UTC
Affected services
Management Panel - panel.nemeahosting.com

Resolved
May 2, 2026 at 10:14am UTC

Issues resolved.

Created
May 1, 2026 at 3:59pm UTC

Due to host-related issues, the panel and EX-EU-UK-01 will be down for an unknown amount of time. We are in direct contact, and are waiting for the team to fix the issue.