Back to overview
Resolved

Panel Provider Down

May 14, 2026 at 9:54am UTC  –  May 14, 2026 at 12:19pm UTC
Affected services
Management Panel - panel.nemeahosting.com

Resolved
May 14, 2026 at 12:19pm UTC

Maintenance ended

Created
May 14, 2026 at 9:54am UTC

After our move to the new provider, the new provider has experienced downtime. This will be a one-off, and shouldn't happen in the near future.