Back to overview
Resolved
DDoS Attacks - Spain
May 20, 2026 at 2:25pm UTC
–
May 20, 2026 at 2:27pm UTC
Affected services
EU-ES-01 - Spain
Resolved
May 20, 2026 at 2:27pm UTC
Maintenance ended
Affected services
Created
May 20, 2026 at 2:25pm UTC
We have identified a DDoS attack against our Spain region.
Affected services