Back to overview
Resolved

Homepage Down

May 28, 2026 at 3:57pm UTC  –  May 31, 2026 at 6:10pm UTC
Affected services
Landing Page - nemeahosting.com

Resolved
May 31, 2026 at 6:10pm UTC

Maintenance ended

Updated
May 31, 2026 at 6:10pm UTC

Resolved.

Created
May 28, 2026 at 3:57pm UTC

We are investigating issues related to the homepage - nemea.uk not responding.