Back to overview
Resolved
Spain Region Maintenance
Jun 8, 2026 at 4:44pm UTC
Affected services
Landing Page - nemeahosting.com
EU-ES-01 - Spain
Resolved
Jun 8, 2026 at 5:02pm UTC
We have received confirmation that the Spain region has recovered. We apologise for inconveniences!
Affected services
Created
Jun 8, 2026 at 4:44pm UTC
There will be maintenance on our Spain region for upgrades to the datacentre network. ETA: ~5 minutes
Affected services