Back to overview
Resolved
Spain Downtime
Jun 18, 2026 at 12:47pm UTC
Affected services
Landing Page - nemeahosting.com
EU-ES-01 - Spain
Resolved
Jun 18, 2026 at 1:35pm UTC
The issue has been fixed. We have raised our concerns.
Affected services
Created
Jun 18, 2026 at 12:47pm UTC
Yet again, due to an ISP issue Spain went down for around an hour. We are sorry for these outages and are working with our provider to reduce these.
Affected services