Back to overview
Resolved

Spain Incident

Jun 20, 2026 at 10:00am UTC
Affected services
Landing Page - nemeahosting.com
EU-ES-01 - Spain

Resolved
Jun 20, 2026 at 10:14am UTC

Restart completed.

Created
Jun 20, 2026 at 10:00am UTC

We are restarting the Spain node for routine maintenance.