Back to overview
Resolved

DDoS Attacks

Jun 25, 2026 at 3:13pm UTC
Affected services
Landing Page - nemeahosting.com
Management Panel - panel.nemeahosting.com

Resolved
Jun 25, 2026 at 6:15pm UTC

Panel online

Updated
Jun 25, 2026 at 6:03pm UTC

Panel degraded, Landing Page online.

Updated
Jun 25, 2026 at 5:28pm UTC

Our Management Panel is back online. We are working to bring the Landing Page back.

Created
Jun 25, 2026 at 3:13pm UTC

Our Infrastructure is receiving a large-scale DDoS attack. Services may be down. We are trying to resolve this.