Back to overview
Resolved
MAIL-IN-01 Unresponsive
Jul 20, 2026 at 1:06am UTC
–
Jul 20, 2026 at 7:25pm UTC
Affected services
MAIL-IN-01
Resolved
Jul 20, 2026 at 7:25pm UTC
[POST RESOLVED] The issue was the dedicated server was shut off by a technician.
Affected services
Updated
Jul 21, 2026 at 5:08pm UTC
We are still investigating.
Affected services
Created
Jul 20, 2026 at 1:06am UTC
MAIL-IN-01: Our Staff Mailserver is Unresponsive. We have no idea what caused this and we are investigating the cause.
Affected services