Back to overview
Resolved

UK Region Power Maintenance

Aug 3, 2026 at 2:17pm UTC
Affected services
EU-UK-01 - Truro

Resolved
Aug 3, 2026 at 3:23pm UTC

Resolved. Thankyou for your patience.

Created
Aug 3, 2026 at 2:17pm UTC

We are performing maintenance in our UK region to ensure stability. The estimated downtime is around 20 minutes.